Scheduled for July 13, 2023 at 7:36 PM – 9:26 PM
Completed
July 13, 2023 at 9:26 PMCompleted
July 13, 2023 at 9:26 PMMaintenance has completed successfully.
Update
July 13, 2023 at 7:41 PMPlanned
July 13, 2023 at 7:41 PMWe are planning for a scheduled maintenance during that time.
Planned
July 13, 2023 at 7:36 PMPlanned
July 13, 2023 at 7:36 PMWe are planning for a scheduled maintenance during that time.